What's a "pstoraster" and How do I fix a "broken" one?

edited January 2012 in advice
Tried printing a single page of Acrobat pdf on my HP LaserJet P1005 from my iMac, and received the message:

"/usr/libexec/cups/filter/pstoraster failed"

Had to open the page in Preview and print from there, no problem.

But that's a workaround. How do I fix that failing pstoraster?


  • It's probably a postscript errors. If you've only got Preview, save the offending page as an image file, then print. Or, if you've got Acrobat Reader there should (or use to) be an option to print as image...
  • Does any other PDF fail on you, or just this one? CUPS is your printer stuff, PSTORASTER is postscript rendering.
  • I think it's all pdf files that won't print through Acrobat. I use the printer for only a few sheets every few months, so I need it very rarely, but do need something.

    I haven't tried printing through Reader (don't actually have it in my Applications folder) but I know Preview will open the pdf file and print it, so it is a good workaround.

    I'd just like things to work as they're supposed to ! :D
Sign In or Register to comment.